This issue is now resolved. Please submit a ticket to Digital Support if you receive any further reports of cash ITM deposits being held.
Posted Sep 04, 2026 - 09:41 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 15:27 EDT
Investigating
We have been made aware of issues involving ITMs holding cash deposits. We currently have an open ticket with NCR and are working with them to resolve this issue. We will keep you updated as we find out more information.