Westgate ITMs & Drive Thru

Incident Report for Directions Credit Union

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 15:05 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 16:15 EDT

Investigating

Both of Westgate's drive thru lanes will be closed at this time due to an issue with the building.
There is no current estimated time of resolution.
Posted Sep 04, 2026 - 09:34 EDT
This incident affected: Branch Network and ITMs.